GitHub Advisoryadvisory · Maven

GHSA-q9hr-3pg4-3jp4 Improper Input Validation in Apache ActiveMQ

CRITICAL Published 2022-05-13 Modified 2023-12-20 Official page ↗
Aliases
CVE-2015-5254
Ecosystem
Maven
Packages
org.apache.activemq:activemq-client
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2022-07-06

Affected packages

• Maven org.apache.activemq:activemq-client: >= 5.0.0, < 5.11.3 → fixed in 5.11.3 • Maven org.apache.activemq:activemq-client: >= 5.12.0, < 5.12.2 → fixed in 5.12.2

Description

Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMessage object.

Related

Alias · CVE (1)

  • CVE-2015-5254 Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References