GitHub Advisoryadvisory · Packagist
GHSA-q9xx-4689-gvv5 Magento Unauthorized access to restricted resources
MEDIUM
Official page ↗
- Aliases
- CVE-2021-28563
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-285
- Reviewed
- 2024-01-10
Affected packages
• Packagist magento/community-edition: >= 2.4.0, < 2.4.2-p1 → fixed in 2.4.2-p1
• Packagist magento/community-edition: < 2.3.7 → fixed in 2.3.7
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization vulnerability via the 'Create Customer' endpoint. Successful exploitation could lead to unauthorized modification of customer data by an unauthenticated attacker. Access to the admin console is required for successful exploitation.
Related
Alias · CVE (1)
- CVE-2021-28563 Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization… vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-28563 advisory
- https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695 web
- https://github.com/magento/magento2/commit/ed952726c94e401e922e88490e41a536f2d850e7 web
- https://github.com/magento/magento2 package
- https://helpx.adobe.com/security/products/magento/apsb21-30.html web