GitHub Advisoryadvisory · Packagist
GHSA-qc43-78vj-vg7p SimpleSAMLphp Authentication context bypass in the multiauth module
HIGH
Official page ↗
- Aliases
- CVE-2017-12869
- Ecosystem
- Packagist
- Packages
- simplesamlphp/simplesamlphp
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-04-25
Affected packages
• Packagist simplesamlphp/simplesamlphp: < 1.14.14 → fixed in 1.14.14
Description
The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via vectors related to improper validation of user input.
Related
Alias · CVE (1)
- CVE-2017-12869 The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-12869 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-12869.yaml web
- https://github.com/simplesamlphp/simplesamlphp package
- https://github.com/simplesamlphp/simplesamlphp/blob/de98fc5bb663feea16686ae77958f759b4a7638d/docs/simplesamlphp-changelog-1.x.md?plain=1#L902C64-L902C79 web
- https://lists.debian.org/debian-lts-announce/2017/12/msg00007.html web
- https://simplesamlphp.org/security/201704-02 web
- https://www.debian.org/security/2018/dsa-4127 web