GitHub Advisoryadvisory · PyPI

GHSA-qc53-44cj-vfvx Denial of Service in Tensorflow

MEDIUM Published 2020-09-25 Modified 2024-10-28 Official page ↗
Aliases
CVE-2020-15197
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:H
Weaknesses
CWE-20, CWE-617
Reviewed
2020-09-25

Affected packages

• PyPI tensorflow: >= 2.3.0, < 2.3.1 → fixed in 2.3.1 • PyPI tensorflow-cpu: >= 2.3.0, < 2.3.1 → fixed in 2.3.1 • PyPI tensorflow-gpu: >= 2.3.0, < 2.3.1 → fixed in 2.3.1

Description

Impact The `SparseCountSparseOutput` implementation does not validate that the input arguments form a valid sparse tensor. In particular, there is no validation that the `indices` tensor has rank 2. This tensor must be a matrix because code assumes its elements are accessed as elements of a matrix: https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/core/kernels/count_ops.cc#L185 However, malicious users can pass in tensors of different rank, resulting in a `CHECK` assertion failure and a crash. This can be used to cause denial of service in serving installations, if users are allowed to control the components of the input sparse tensor. Patches We have patched the issue in 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and will release a patch release. We recommend users to upgrade to TensorFlow 2.3.1. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability is a variant of GHSA-p5f8-gfw5-33w4

Related

Alias · CVE (1)

  • CVE-2020-15197 In Tensorflow before version 2.3.1, the `SparseCountSparseOutput` implementation does not validate that the input arguments form a valid… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-617 Reachable Assertion weakness

References