GitHub Advisoryadvisory · Packagist
GHSA-qc86-vgf2-6fq6 Moodle SQL Injection vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2021-36392
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2023-03-07
Affected packages
• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1
• Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5
• Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8
Description
In Moodle, an SQL injection risk was identified in the library fetching a user's enrolled courses.
Related
Alias · CVE (1)
- CVE-2021-36392 In Moodle, an SQL injection risk was identified in the library fetching a user's enrolled courses. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness