GitHub Advisoryadvisory · PyPI

GHSA-qccg-9m4q-xfm6 DB-GPT is vulnerable to SQL Injection attacks from unauthenticated users

CRITICAL Published 2025-03-20 Modified 2026-10-27 Official page ↗
Aliases
CVE-2024-10835
Ecosystem
PyPI
Packages
dbgpt
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-89
Reviewed
2025-07-17

Affected packages

• PyPI dbgpt: < 0.7.1 → fixed in 0.7.1

Description

In eosphoros-ai/db-gpt version v0.6.0, the web API `POST /api/v1/editor/sql/run` allows execution of arbitrary SQL queries without any access control. This vulnerability can be exploited by attackers to perform Arbitrary File Write using DuckDB SQL, enabling them to write arbitrary files to the victim's file system. This can potentially lead to Remote Code Execution (RCE).

Related

Alias · CVE (1)

  • CVE-2024-10835 In eosphoros-ai/db-gpt version v0.6.0, the web API `POST /api/v1/editor/sql/run` allows execution of arbitrary SQL queries without any… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References