GitHub Advisoryadvisory · PyPI

GHSA-qcgg-j2x8-h9g8 Django has a potential denial-of-service vulnerability in IPv6 validation

MEDIUM Published 2025-01-14 Modified 2025-05-20 Official page ↗
Aliases
CVE-2024-56374
Ecosystem
PyPI
Packages
Django, django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Weaknesses
CWE-770
Reviewed
2025-01-14

Affected packages

• PyPI Django: >= 5.1, < 5.1.5 → fixed in 5.1.5 • PyPI Django: >= 5.0, < 5.0.11 → fixed in 5.0.11 • PyPI Django: >= 4.2, < 4.2.18 → fixed in 4.2.18 • PyPI django: >= 5.1, < 5.1.5 → fixed in 5.1.5 • PyPI django: >= 5.0, < 5.0.11 → fixed in 5.0.11 • PyPI django: >= 4.2, < 4.2.18 → fixed in 4.2.18

Description

An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a potential denial-of-service attack. The undocumented and private functions `clean_ipv6_address` and `is_valid_ipv6_address` are vulnerable, as is the `django.forms.GenericIPAddressField` form field. (The django.db.models.GenericIPAddressField model field is not affected.)

Related

Alias · CVE (1)

  • CVE-2024-56374 An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References