GitHub Advisoryadvisory · Go

GHSA-qcjq-7f7v-pvc8 Nginx-UI vulnerable to authenticated RCE through injecting into the application config via CRLF

HIGH Published 2024-01-29 Modified 2026-07-06 Official page ↗
Aliases
CVE-2024-23828
Ecosystem
Go
Packages
github.com/0xJacky/Nginx-UI
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74
Reviewed
2024-01-29

Affected packages

• Go github.com/0xJacky/Nginx-UI: < 1.9.10-0.20240126104956-d70e37c8575e → fixed in 1.9.10-0.20240126104956-d70e37c8575e

Description

Summary Fix bypass to the following bugs • https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-pxmr-q2x3-9x9m • https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-8r25-68wm-jw35 Allowing to inject directly in the `app.ini` via CRLF to change the value of `test_config_cmd` and `start_cmd` resulting in an Authenticated RCE Impact Authenticated Remote execution on the host

Related

Alias · CVE (1)

  • CVE-2024-23828 Nginx-UI is a web interface to manage Nginx configurations. vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References