GitHub Advisoryadvisory · Packagist
GHSA-qcv6-h33g-hvrc Cross-site Scripting (XSS) within joomla/filter class
MEDIUM
Official page ↗
- Aliases
- CVE-2022-23800
- Ecosystem
- Packagist
- Packages
- joomla/filter
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-15
Affected packages
• Packagist joomla/filter: < 1.4.4 → fixed in 1.4.4
• Packagist joomla/filter: >= 2.0.0, < 2.0.1 → fixed in 2.0.1
Description
An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.
Related
Alias · CVE (1)
- CVE-2022-23800 An issue was discovered in Joomla! vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23800 advisory
- https://developer.joomla.org/security-centre/877-20220308-core-inadequate-content-filtering-within-the-filter-code.html web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/joomla/filter/CVE-2022-23800.yaml web
- https://github.com/joomla-framework/filter package