GitHub Advisoryadvisory · Maven

GHSA-qcxh-w3j9-58qr Apache Tomcat Denial of Service vulnerability

HIGH Published 2020-06-15 Modified 2026-05-20 Official page ↗
Aliases
CVE-2019-0199
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-coyote
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2020-06-15

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0, < 9.0.16 → fixed in 9.0.16 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.0.0, < 8.5.38 → fixed in 8.5.38 • Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0, < 9.0.16 → fixed in 9.0.16 • Maven org.apache.tomcat:tomcat-coyote: >= 8.0.0, < 8.5.38 → fixed in 8.5.38

Description

The HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.14 and 8.5.0 to 8.5.37 accepted streams with excessive numbers of SETTINGS frames and also permitted clients to keep streams open without reading/writing request/response data. By keeping streams open for requests that utilised the Servlet API's blocking I/O, clients were able to cause server-side threads to block eventually leading to thread exhaustion and a DoS.

Related

Alias · CVE (1)

  • CVE-2019-0199 The HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.14 and 8.5.0 to 8.5.37 accepted streams with excessive numbers of SETTINGS… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References