GitHub Advisoryadvisory · Maven

GHSA-qf38-f2fr-q4x9 Improper Input Validation in Jenkins

HIGH Published 2022-05-13 Modified 2022-06-28 Official page ↗
Aliases
CVE-2018-1999002
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-20
Reviewed
2022-06-28

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: < 2.121.2 → fixed in 2.121.2 • Maven org.jenkins-ci.main:jenkins-core: >= 2.122, < 2.132 → fixed in 2.132

Description

A arbitrary file read vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers to send crafted HTTP requests returning the contents of any file on the Jenkins master file system that the Jenkins master has access to.

Related

Alias · CVE (1)

  • CVE-2018-1999002 A arbitrary file read vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References