GitHub Advisoryadvisory · Packagist

GHSA-qf6m-6m4g-rmrc Mautic has insufficient authentication in upgrade flow

MEDIUM Published 2024-09-18 Modified 2025-02-21 Official page ↗
Aliases
CVE-2022-25770
Ecosystem
Packagist
Packages
mautic/core, mautic/core-lib
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weaknesses
CWE-306
Reviewed
2024-09-18

Affected packages

• Packagist mautic/core: >= 1.0.0-beta3, < 4.4.13 → fixed in 4.4.13 • Packagist mautic/core: >= 5.0.0-alpha, < 5.1.1 → fixed in 5.1.1 • Packagist mautic/core-lib: >= 1.0.0-beta3, < 4.4.13 → fixed in 4.4.13 • Packagist mautic/core-lib: >= 5.0.0-alpha, < 5.1.1 → fixed in 5.1.1

Description

Impact Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable Patches Please upgrade to 4.4.1 or 5.1.1 or later. Workarounds None. For more information If you have any questions or comments about this advisory: • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2022-25770 Mautic allows you to update the application via an upgrade script. vulnerability

Weakness · CWE (1)

  • CWE-306 Missing Authentication for Critical Functionality weakness

References