GitHub Advisoryadvisory · PyPI

GHSA-qfhq-4f3w-5fph PyTorch is vulnerable to memory corruption through its torch.lstm_cell function

LOW Published 2025-03-31 Modified 2026-06-10 Official page ↗
Aliases
CVE-2025-3001
Ecosystem
PyPI
Packages
torch
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-119
Reviewed
2026-06-10

Affected packages

• PyPI torch: < 2.10.0 → fixed in 2.10.0

Description

A vulnerability classified as critical was found in PyTorch 2.6.0. This vulnerability affects the function torch.lstm_cell. The manipulation leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. A patch is available through commit 999d94b.

Related

Alias · CVE (1)

  • CVE-2025-3001 A vulnerability classified as critical was found in PyTorch 2.6.0. vulnerability

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References