GitHub Advisoryadvisory · Maven

GHSA-qfw7-pfxx-h9q2 OpenNMS vulnerable to Cross-site Scripting

MEDIUM Published 2023-08-14 Modified 2023-08-23 Official page ↗
Aliases
CVE-2023-40311
Ecosystem
Maven
Packages
org.opennms:opennms-webapp
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2023-08-14

Affected packages

• Maven org.opennms:opennms-webapp: >= 31.0.8, < 32.0.2 → fixed in 32.0.2

Description

Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.

Related

Alias · CVE (1)

  • CVE-2023-40311 Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References