GitHub Advisoryadvisory · PyPI
GHSA-qg33-x2c5-6p44 Langflow remote code execution vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-37014
- Ecosystem
- PyPI
- Packages
- langflow
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-913, CWE-94
- Reviewed
- 2024-06-11
Affected packages
• PyPI langflow: < 1.0.15 → fixed in 1.0.15
Description
Langflow allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.
Related
Alias · CVE (1)
- CVE-2024-37014 Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and… vulnerability