GitHub Advisoryadvisory · PyPI
GHSA-qg47-5px9-32g7 Ansible Remote Code Execution
CRITICAL
Official page ↗
- Aliases
- CVE-2014-4657
- Ecosystem
- PyPI
- Packages
- ansible
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-08-07
Affected packages
• PyPI ansible: < 1.5.4 → fixed in 1.5.4
Description
The `safe_eval` function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Related
Alias · CVE (1)
- CVE-2014-4657 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-4657 advisory
- https://github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c web
- https://github.com/ansible/ansible package
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md web
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-199.yaml web
- https://web.archive.org/web/20210120133852/https://www.securityfocus.com/bid/68232 web