GitHub Advisoryadvisory · RubyGems

GHSA-qg54-694p-wgpp Regular expression denial of service vulnerability (ReDoS) in date

HIGH Published 2021-11-16 Modified 2024-01-24 Official page ↗
Aliases
CVE-2021-41817
Ecosystem
RubyGems
Packages
date
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1333
Reviewed
2021-11-16

Affected packages

• RubyGems date: >= 3.2.0, < 3.2.1 → fixed in 3.2.1 • RubyGems date: >= 3.1.0, < 3.1.2 → fixed in 3.1.2 • RubyGems date: >= 3.0.0, < 3.0.2 → fixed in 3.0.2 • RubyGems date: < 2.0.1 → fixed in 2.0.1

Description

Date’s parsing methods including Date.parse are using Regexps internally, some of which are vulnerable against regular expression denial of service. Applications and libraries that apply such methods to untrusted input may be affected. The fix limits the input length up to 128 bytes by default instead of changing the regexps. This is because Date gem uses many Regexps and it is possible that there are still undiscovered vulnerable Regexps. For compatibility, it is allowed to remove the limitation by explicitly passing limit keywords as nil like Date.parse(str, limit: nil), but note that it may take a long time to parse. Please update the date gem to version 3.2.1, 3.1.2, 3.0.2, and 2.0.1, or later. You can use gem update date to update it. If you are using bundler, please add gem "date", ">= 3.2.1" to your Gemfile. If you import `date` from the standard library rather than as a gem you should update your Ruby install to `3.0.3`, `2.7.5`, `2.6.9` or later. Users unable to upgrade may consider using `Date.strptime` instead with a predefined date format ```ruby Date.strptime('2001-02-20', '%Y-%m-%d') ```

Related

Alias · CVE (1)

  • CVE-2021-41817 Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. vulnerability

Weakness · CWE (1)

  • CWE-1333 Inefficient Regular Expression Complexity weakness

References