GitHub Advisoryadvisory · Packagist
GHSA-qg5v-jw6f-rpfj SabreDAV Directory Traversal vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2013-1939
- Ecosystem
- Packagist
- Packages
- sabre/dav
- Severity
- Moderate
- Weaknesses
- CWE-20, CWE-22
- Reviewed
- 2023-07-07
Affected packages
• Packagist sabre/dav: >= 1.7.0, < 1.7.7 → fixed in 1.7.7
• Packagist sabre/dav: >= 1.8.0, < 1.8.5 → fixed in 1.8.5
• Packagist sabre/dav: >= 1.6.0, < 1.6.9 → fixed in 1.6.9
Description
The HTML\Browser plugin in SabreDAV before 1.6.9, 1.7.x before 1.7.7, and 1.8.x before 1.8.5, as used in ownCloud, when running on Windows, does not properly check path separators in the base path, which allows remote attackers to read arbitrary files via a `\` (backslash) character.
Related
Alias · CVE (1)
- CVE-2013-1939 The HTML\Browser plugin in SabreDAV before 1.6.9, 1.7.x before 1.7.7, and 1.8.x before 1.8.5, as used in ownCloud, when running on Windows,… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-1939 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/sabre/dav/CVE-2013-1939.yaml web
- https://github.com/sabre-io/dav package
- https://groups.google.com/forum/?fromgroups=#!topic/sabredav-discuss/ehOUu7wTSGQ web
- https://groups.google.com/forum/?fromgroups=#%21topic/sabredav-discuss/ehOUu7wTSGQ web
- http://owncloud.org/about/security/advisories/oC-SA-2013-016 web