GitHub Advisoryadvisory · Packagist
GHSA-qg7c-q3vq-rgxr Leak of information via Store-API aggregations in shopware/platform and shopware/core
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- shopware/core, shopware/platform
- Severity
- Critical
- Weaknesses
- CWE-668
- Reviewed
- 2021-04-12
Affected packages
• Packagist shopware/core: < 6.3.5.3 → fixed in 6.3.5.3
• Packagist shopware/platform: < 6.3.5.3 → fixed in 6.3.5.3
Description
Impact
Leak of information via Store-API
Patches
We recommend to update to the current version 6.3.5.3. You can get the update to 6.3.5.3 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-04-2021
Related
Weakness · CWE (1)
- CWE-668 Exposure of Resource to Wrong Sphere weakness