GitHub Advisoryadvisory · npm

GHSA-qgp8-v765-qxx9 @cloudflare/workers-oauth-provider PKCE bypass via downgrade attack

MEDIUM Published 2025-05-01 Modified 2025-05-01 Official page ↗
Aliases
CVE-2025-4144
Ecosystem
npm
Packages
@cloudflare/workers-oauth-provider
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-287
Reviewed
2025-05-01

Affected packages

• npm @cloudflare/workers-oauth-provider: < 0.0.5 → fixed in 0.0.5

Description

Summary PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework. However, it was found that an attacker could cause the check to be skipped. Impact PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.) This bug completely bypasses PKCE protection. Patches Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 We patched up the vulnerabilities in the latest version, v 0.0.5 of the Workers OAuth provider (https://www.npmjs.com/package/@cloudflare/workers-oauth-provider). You'll need to update your MCP servers to use that version to resolve the vulnerability. Workarounds None

Related

Alias · CVE (1)

  • CVE-2025-4144 PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References