GitHub Advisoryadvisory · PyPI

GHSA-qh4q-fwf8-qqrw Zope Denial of Service (DoS) vulnerability in ZServer

HIGH Published 2022-05-17 Modified 2026-05-29 Official page ↗
Aliases
CVE-2010-3198
Ecosystem
PyPI
Packages
Zope
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2024-02-08

Affected packages

• PyPI Zope: >= 2.10.0, < 2.10.12 → fixed in 2.10.12 • PyPI Zope: >= 2.11.0, < 2.11.7 → fixed in 2.11.7

Description

ZServer in Zope 2.10.x before 2.10.12 and 2.11.x before 2.11.7 allows remote attackers to cause a denial of service (crash of worker threads) via vectors that trigger uncaught exceptions.

Related

Alias · CVE (1)

  • CVE-2010-3198 ZServer in Zope 2.10.x before 2.10.12 and 2.11.x before 2.11.7 allows remote attackers to cause a denial of service (crash of worker… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References