GitHub Advisoryadvisory · Packagist
GHSA-qh8m-6g4p-33h3 Moodle Improper Authentication
HIGH
Official page ↗
- Aliases
- CVE-2018-1082
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.3, < 3.3.5 → fixed in 3.3.5
• Packagist moodle/moodle: >= 3.4, < 3.4.2 → fixed in 3.4.2
Description
A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.
Related
Alias · CVE (1)
- CVE-2018-1082 A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness