GitHub Advisoryadvisory · npm
GHSA-qh9x-gcfh-pcrw OpenZeppelin Contracts's ERC165Checker may revert instead of returning false
HIGH
Official page ↗
- Aliases
- CVE-2022-31170
- Ecosystem
- npm
- Packages
- @openzeppelin/contracts, @openzeppelin/contracts-upgradeable
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20, CWE-252
- Reviewed
- 2022-07-21
Affected packages
• npm @openzeppelin/contracts: >= 4.0.0, < 4.7.1 → fixed in 4.7.1
• npm @openzeppelin/contracts-upgradeable: >= 4.0.0, < 4.7.1 → fixed in 4.7.1
Description
Impact
`ERC165Checker.supportsInterface` is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-165 as expected, specifically if it returns a value other than 0 or 1.
The contracts that may be affected are those that use `ERC165Checker` to check for support for an interface and then handle the lack of support in a way other than reverting.
Patches
The issue was patched in 4.7.1.
References
https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552
For more information
If you have any questions or comments about this advisory, or need assistance deploying the fix, email us at [email protected].
Related
Alias · CVE (1)
- CVE-2022-31170 OpenZeppelin Contracts is a library for smart contract development. vulnerability