GitHub Advisoryadvisory · RubyGems, Maven

GHSA-qj2w-mw2r-pv39 RubyGems Deserialization of Untrusted Data vulnerability

HIGH Published 2022-05-14 Modified 2023-03-10 Official page ↗
Aliases
CVE-2018-1000074
Ecosystem
RubyGems, Maven
Packages
rubygems-update, org.jruby:jruby-stdlib
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2023-03-10

Affected packages

• RubyGems rubygems-update: < 2.7.6 → fixed in 2.7.6 • Maven org.jruby:jruby-stdlib: < 9.1.16.0 → fixed in 9.1.16.0

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack requires the victim to run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability is fixed in 2.7.6.

Related

Alias · CVE (1)

  • CVE-2018-1000074 RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References