GitHub Advisoryadvisory · Packagist

GHSA-qjx3-2g35-6hv8 Mautic Sensitive Data Exposure due to inadequate user permission settings

HIGH Published 2024-04-12 Modified 2024-09-18 Official page ↗
Aliases
CVE-2022-25776
Ecosystem
Packagist
Packages
mautic/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H
Weaknesses
CWE-276, CWE-280
Reviewed
2024-04-12

Affected packages

• Packagist mautic/core: >= 1.0.2, < 4.4.12 → fixed in 4.4.12 • Packagist mautic/core: >= 5.0.0-alpha, < 5.0.4 → fixed in 5.0.4

Description

Impact Prior to the patched version, logged in users of Mautic are able to access areas of the application that they should be prevented from accessing. Users could potentially access sensitive data such as names and surnames, company names and stage names. Patches Update to 4.4.12 and 5.0.4 Workarounds No References https://owasp.org/www-project-top-ten/2017/A3_2017-Sensitive_Data_Exposure

Related

Alias · CVE (1)

  • CVE-2022-25776 Prior to the patched version, logged in users of Mautic are able to access areas of the application that they should be prevented from… vulnerability

Weakness · CWE (2)

  • CWE-276 Incorrect Default Permissions weakness
  • CWE-280 Improper Handling of Insufficient Permissions or Privileges weakness

References