GitHub Advisoryadvisory · npm

GHSA-qm2m-28pf-hgjw OpenClaw: Gateway Plugin HTTP Auth Grants Unrestricted operator.admin Runtime Scope to All Callers

HIGH Published 2026-03-27 Modified 2026-04-10 Official page ↗
Aliases
CVE-2026-35669
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-266, CWE-863
Reviewed
2026-03-27

Affected packages

• npm openclaw: <= 2026.3.24 (no fix yet)

Description

Summary Gateway Plugin HTTP auth: "gateway" Mints operator.admin Runtime Scope Affected Packages / Versions • Package: `openclaw` • Affected versions: `<= 2026.3.24` • First patched version: `2026.3.25` • Latest published npm version at verification time: `2026.3.24` Details Gateway-authenticated plugin HTTP routes previously created a runtime scope set that included `operator.admin` regardless of caller-granted scopes. Commit `ec2dbcff9afd8a52e00de054b506c91726d9fbbe` keeps plugin HTTP runtime scopes least-privileged and preserves caller scope boundaries. Verified vulnerable on tag `v2026.3.24` and fixed on `main` by commit `ec2dbcff9afd8a52e00de054b506c91726d9fbbe`. Fix Commit(s) • `ec2dbcff9afd8a52e00de054b506c91726d9fbbe`

Related

Alias · CVE (1)

  • CVE-2026-35669 OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in gateway-authenticated plugin HTTP routes that incorrectly mint… vulnerability

Weakness · CWE (2)

  • CWE-266 Incorrect Privilege Assignment weakness
  • CWE-863 Incorrect Authorization weakness

References