GitHub Advisoryadvisory · npm
GHSA-qmc2-jpr5-7rg9 Backstage Scaffolder plugin vulnerable to Server-Side Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2024-53983
- Ecosystem
- npm
- Packages
- @backstage/plugin-scaffolder-node
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2024-12-02
Affected packages
• npm @backstage/plugin-scaffolder-node: < 0.4.12 → fixed in 0.4.12
• npm @backstage/plugin-scaffolder-node: >= 0.5.0, < 0.5.1 → fixed in 0.5.1
• npm @backstage/plugin-scaffolder-node: >= 0.6.0, < 0.6.1 → fixed in 0.6.1
Description
Impact
A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin.
Patches
The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability.
Workarounds
Users can ensure that templates do not change git config.
References
If you have any questions or comments about this advisory:
Open an issue in the Backstage repository
Visit our Discord, linked to in Backstage README
Related
Alias · CVE (1)
- CVE-2024-53983 The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness