GitHub Advisoryadvisory · PyPI
GHSA-qmhj-m29v-gvmr Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution
HIGH
Official page ↗
- Aliases
- CVE-2022-36024
- Ecosystem
- PyPI
- Packages
- py-cord
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2022-08-18
Affected packages
• PyPI py-cord: >= 2.0.0, < 2.0.1 → fixed in 2.0.1
Description
Impact
py-cord is a an API wrapper for Discord written in Python. Bots using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected.
Patches
This issue has been patched in version 2.0.1.
Workarounds
There are currently no recommended workarounds - please upgrade to a patched version.
References
https://github.com/Pycord-Development/pycord/pull/1568
For more information
If you have any questions or comments about this advisory:
• Open an issue in our GitHub
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2022-36024 py-cord is a an API wrapper for Discord written in Python. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/Pycord-Development/pycord/security/advisories/GHSA-qmhj-m29v-gvmr web
- https://nvd.nist.gov/vuln/detail/CVE-2022-36024 advisory
- https://github.com/Pycord-Development/pycord/pull/1568 web
- https://github.com/Pycord-Development/pycord package
- https://github.com/pypa/advisory-database/tree/main/vulns/py-cord/PYSEC-2022-43146.yaml web