GitHub Advisoryadvisory · Maven
GHSA-qmhq-876f-cr65 Jenkins Jira Plugin vulnerable to exposure of system-scoped credentials
MEDIUM
Official page ↗
- Aliases
- CVE-2023-49653
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:jira
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2023-11-29
Affected packages
• Maven org.jenkins-ci.plugins:jira: < 3.12 → fixed in 3.12
Description
Jenkins Jira Plugin 3.11 and earlier does not set the appropriate context for credentials lookup, allowing the use of system-scoped credentials otherwise reserved for the global configuration.
This allows attackers with Item/Configure permission to access and capture credentials they are not entitled to.
Jira Plugin 3.12 defines the appropriate context for credentials lookup.
Related
Alias · CVE (1)
- CVE-2023-49653 Jenkins Jira Plugin 3.11 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness