GitHub Advisoryadvisory · Packagist

GHSA-qmmw-ch2q-j6xx Typo3 Backend API XSS Vulnerability

LOW Published 2022-05-17 Modified 2024-01-12 Official page ↗
Aliases
CVE-2012-6147
Ecosystem
Packagist
Packages
typo3/cms
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-01-12

Affected packages

• Packagist typo3/cms: >= 4.5.0, < 4.5.21 → fixed in 4.5.21 • Packagist typo3/cms: >= 4.6.0, < 4.6.14 → fixed in 4.6.14 • Packagist typo3/cms: >= 4.7.0, < 4.7.6 → fixed in 4.7.6

Description

Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2012-6147 Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References