GitHub Advisoryadvisory · Packagist

GHSA-qmqw-mpqp-mr54 Symfony Incorrect Access Control

MEDIUM Published 2022-05-17 Modified 2024-02-08 Official page ↗
Aliases
CVE-2015-4050
Ecosystem
Packagist
Packages
symfony/http-kernel, symfony/symfony
Severity
Moderate
Weaknesses
CWE-284
Reviewed
2023-08-03

Affected packages

• Packagist symfony/http-kernel: >= 2.3.19, < 2.3.29 → fixed in 2.3.29 • Packagist symfony/http-kernel: >= 2.5.4, < 2.5.12 → fixed in 2.5.12 • Packagist symfony/http-kernel: >= 2.6.0, < 2.6.8 → fixed in 2.6.8 • Packagist symfony/symfony: >= 2.3.19, < 2.3.29 → fixed in 2.3.29 • Packagist symfony/symfony: >= 2.4.9, <= 2.4.10 (no fix yet) • Packagist symfony/symfony: >= 2.5.4, < 2.5.12 → fixed in 2.5.12 • Packagist symfony/symfony: >= 2.6.0, < 2.6.8 → fixed in 2.6.8 • Packagist symfony/http-kernel: >= 2.4.9, <= 2.4.10 (no fix yet)

Description

FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0 through 2.6.7, when ESI or SSI support enabled, does not check if the `_controller` attribute is set, which allows remote attackers to bypass URL signing and security rules by including (1) no hash or (2) an invalid hash in a request to `/_fragment`. This issue has been fixed in Symfony 2.3.29, 2.5.12, and 2.6.8. Note that no fixes are provided for Symfony 2.4 as it's not maintained anymore.

Related

Alias · CVE (1)

  • CVE-2015-4050 FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References