GitHub Advisoryadvisory · npm
GHSA-qp2q-6h9j-jg2r Cross-site Scripting in jquery.json-viewer
MEDIUM
Official page ↗
- Aliases
- CVE-2022-30241
- Ecosystem
- npm
- Packages
- jquery.json-viewer
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-05-23
Affected packages
• npm jquery.json-viewer: < 1.5.0 → fixed in 1.5.0
Description
The jquery.json-viewer library before version 1.5.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
Related
Alias · CVE (1)
- CVE-2022-30241 The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness