GitHub Advisoryadvisory · npm

GHSA-qpv8-4pjq-qqh7 feathers-sequelize contains improper input validation leading to SQL injection

CRITICAL Published 2022-10-26 Modified 2023-01-10 Official page ↗
Aliases
CVE-2022-2422
Ecosystem
npm
Packages
feathers-sequelize
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2022-10-31

Affected packages

• npm feathers-sequelize: >= 6.0.0, < 6.3.4 → fixed in 6.3.4

Description

Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.

Related

Alias · CVE (1)

  • CVE-2022-2422 Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References