GitHub Advisoryadvisory · Maven

GHSA-qpwj-mvv7-v3m9 High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2

HIGH Published 2018-10-18 Modified 2020-06-16 Official page ↗
Aliases
CVE-2016-4464
Ecosystem
Maven
Packages
org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2
Severity
High
Weaknesses
CWE-284
Reviewed
2020-06-16

Affected packages

• Maven org.apache.cxf.fediz:fediz-spring: >= 1.2.0, < 1.2.3 → fixed in 1.2.3 • Maven org.apache.cxf.fediz:fediz-spring: >= 1.3.0, < 1.3.1 → fixed in 1.3.1 • Maven org.apache.cxf.fediz:fediz-spring2: >= 1.2.0, < 1.2.3 → fixed in 1.2.3 • Maven org.apache.cxf.fediz:fediz-spring2: >= 1.3.0, < 1.3.1 → fixed in 1.3.1

Description

The application plugins in Apache CXF Fediz 1.2.x before 1.2.3 and 1.3.x before 1.3.1 do not match SAML AudienceRestriction values against configured audience URIs, which might allow remote attackers to have bypass intended restrictions and have unspecified other impact via a crafted SAML token with a trusted signature.

Related

Alias · CVE (1)

  • CVE-2016-4464 The application plugins in Apache CXF Fediz 1.2.x before 1.2.3 and 1.3.x before 1.3.1 do not match SAML AudienceRestriction values against… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References