GitHub Advisoryadvisory · PyPI

GHSA-qpxx-2cwh-r5vh pypickle Incorrect Privilege Assignment vulnerability

MEDIUM Published 2025-05-26 Modified 2025-06-04 Official page ↗
Aliases
CVE-2025-5175
Ecosystem
PyPI
Packages
pypickle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-266
Reviewed
2025-05-27

Affected packages

• PyPI pypickle: < 2.0.0 → fixed in 2.0.0

Description

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Related

Alias · CVE (1)

  • CVE-2025-5175 A vulnerability was found in erdogant pypickle up to 1.1.5. vulnerability

Weakness · CWE (1)

  • CWE-266 Incorrect Privilege Assignment weakness

References