GitHub Advisoryadvisory · npm
GHSA-qq6h-5g6j-q3cm sweetalert2 v11.4.9 and above contains hidden functionality
LOW
Official page ↗
- Ecosystem
- npm
- Packages
- sweetalert2
- Severity
- Low
- Weaknesses
- CWE-912
- Reviewed
- 2022-11-23
Affected packages
• npm sweetalert2: >= 11.4.9, < 11.22.4 → fixed in 11.22.4
Description
`sweetalert2` versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8.
Workaround
Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.
Related
Weakness · CWE (1)
- CWE-912 Hidden Functionality weakness