GitHub Advisoryadvisory · PyPI
GHSA-qqcv-vg9f-5rr3 litellm vulnerable to improper access control in team management
MEDIUM
Official page ↗
- Aliases
- CVE-2024-5710
- Ecosystem
- PyPI
- Packages
- litellm
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-284, CWE-862
- Reviewed
- 2024-06-28
Affected packages
• PyPI litellm: < 1.40.15 → fixed in 1.40.15
Description
berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.
Related
Alias · CVE (1)
- CVE-2024-5710 berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-5710 advisory
- https://github.com/BerriAI/litellm/commit/da3ae00bd68f451ed8ddf0bc0a9fd34bde5554d6 web
- https://github.com/BerriAI/litellm/blob/224148d6133ee50801cb129cbd21ccc213992e25/litellm/proxy/auth/user_api_key_auth.py#L1020 web
- https://github.com/berriai/litellm package
- https://huntr.com/bounties/70897f59-a966-4d93-b71e-745e3da91970 web