GitHub Advisoryadvisory · PyPI
GHSA-qrmm-w4v4-q7f8 Unauthorized access through URL manipulation
HIGH
Official page ↗
- Ecosystem
- PyPI
- Packages
- docassemble
- Severity
- High
- Weaknesses
- CWE-552
- Reviewed
- 2021-05-05
Affected packages
• PyPI docassemble: < 1.2.65 → fixed in 1.2.65
Description
Impact
The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation.
Patches
The vulnerability has been patched in version 1.2.65 of the `master` branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the `stable` branch. The Docker image on docker.io has been patched.
Workarounds
If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen).
Credit
The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio).
For more information
If you have any questions or comments about this advisory:
• Open an issue in docassemble
• Join the Slack channel
• Email us at [email protected]
Related
Weakness · CWE (1)
- CWE-552 Files or Directories Accessible to External Parties weakness