GitHub Advisoryadvisory · npm
GHSA-qrpm-p2h7-hrv2 Exposure of Sensitive Information to an Unauthorized Actor in nanoid
MEDIUM
Official page ↗
- Aliases
- CVE-2021-23566
- Ecosystem
- npm
- Packages
- nanoid
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-704
- Reviewed
- 2022-01-18
Affected packages
• npm nanoid: >= 3.0.0, < 3.1.31 → fixed in 3.1.31
Description
The package nanoid from 3.0.0, before 3.1.31, are vulnerable to Information Exposure via the valueOf() function which allows to reproduce the last id generated.
Related
Alias · CVE (1)
- CVE-2021-23566 The package nanoid from 3.0.0 and before 3.1.31 are vulnerable to Information Exposure via the valueOf() function which allows to reproduce… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-23566 advisory
- https://github.com/ai/nanoid/pull/328 web
- https://github.com/ai/nanoid/commit/2b7bd9332bc49b6330c7ddb08e5c661833db2575 web
- https://gist.github.com/artalar/bc6d1eb9a3477d15d2772e876169a444 web
- https://github.com/ai/nanoid package
- https://lists.debian.org/debian-lts-announce/2024/12/msg00025.html web
- https://lists.debian.org/debian-lts-announce/2025/01/msg00006.html web
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2332550 web
- https://snyk.io/vuln/SNYK-JS-NANOID-2332193 web