GitHub Advisoryadvisory · Packagist
GHSA-qrqm-574x-q7f2 Awesome Support vulnerable to persistent cross-site scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2022-38073
- Ecosystem
- Packagist
- Packages
- awesome-support/awesome-support
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-09-29
Affected packages
• Packagist awesome-support/awesome-support: < 6.0.8 → fixed in 6.0.8
Description
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
Related
Alias · CVE (1)
- CVE-2022-38073 Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38073 advisory
- https://github.com/Awesome-Support/Awesome-Support/commit/85f460be88b81fbdd9a990f474a1252297902faf web
- https://github.com/Awesome-Support/Awesome-Support/commit/b2e831d7f831a3869cfd83eb79a398a5b5c0ec63 web
- https://github.com/Awesome-Support/Awesome-Support package
- https://patchstack.com/database/vulnerability/awesome-support/wordpress-awesome-support-plugin-6-0-7-multiple-authenticated-stored-cross-site-scripting-xss-vulnerabilities web
- https://wordpress.org/plugins/awesome-support/#developers web