GitHub Advisoryadvisory · Packagist

GHSA-qrqv-26gf-xgwh Moodle LFI vulnerability when restoring malformed block backups

MEDIUM Published 2024-11-07 Modified 2024-11-07 Official page ↗
Aliases
CVE-2024-43440
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-22
Reviewed
2024-11-07

Affected packages

• Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12 • Packagist moodle/moodle: >= 4.2.0-beta, < 4.2.9 → fixed in 4.2.9 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.6 → fixed in 4.3.6 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.2 → fixed in 4.4.2

Description

A flaw was found in moodle. A local file may include risks when restoring block backups.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References