GitHub Advisoryadvisory · Go

GHSA-qrrf-xvcf-p64q usememos/memos vulnerable Improper Restriction of Excessive Authentication Attempts

MEDIUM Published 2022-12-28 Modified 2023-01-10 Official page ↗
Aliases
CVE-2022-4797
Ecosystem
Go
Packages
github.com/usememos/memos
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-307
Reviewed
2022-12-30

Affected packages

• Go github.com/usememos/memos: < 0.9.1 → fixed in 0.9.1

Description

In usememos/memos 0.9.0 and prior, an attacker can delete other users' posts via post id, which can be done via brute force.

Related

Alias · CVE (1)

  • CVE-2022-4797 Improper Restriction of Excessive Authentication Attempts in GitHub repository usememos/memos prior to 0.9.1. vulnerability

Weakness · CWE (1)

  • CWE-307 Improper Restriction of Excessive Authentication Attempts weakness

References