GitHub Advisoryadvisory · Packagist

GHSA-qv78-c8hc-438r OpenMage vulnerable to XSS in Admin Notifications

MEDIUM Published 2025-11-03 Modified 2025-11-06 Official page ↗
Aliases
CVE-2025-64174
Ecosystem
Packagist
Packages
openmage/magento-lts
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2025-11-03

Affected packages

• Packagist openmage/magento-lts: < 20.16.0 → fixed in 20.16.0

Description

Summary OpenMage versions v20.15.0 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Details Unescaped translation strings and URLs are printed into contexts inside `app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php`. A malicious translation or polluted data can inject script. • Link labels use __() without escaping. • ’deleteConfirm()’ embeds a message without escaping. PoC 1. Add XSS to admin locale (e.g. app/locale/en_US/local.csv): ``` "Read Details","" "Mark as Read","alert(123)" ``` 2. Flush Cache. Make sure locale is set to en_US. 3. Add any admin notification (e.g. via test.php) ``` setData([ 'severity' => Mage_AdminNotification_Model_Inbox::SEVERITY_NOTICE, 'date_added' => now(), 'title' => 'XSS renderer test', 'description' => 'Testing actions renderer', 'url' => 'https://example.com', // makes the "Read Details" link appear 'is_read' => 0, // makes the "Mark as Read" link appear 'is_remove' => 0, ])->save(); ``` 4. Open Admin → System → Notifications → Inbox. 5. Profit. Impact The vulnerability is only exploitable by an attacker with administrative or translation privileges. Malicious JavaScript may be executed in a victim’s browser when they browse to the admin page containing the vulnerable fields.

Related

Alias · CVE (1)

  • CVE-2025-64174 Magento-lts is a long-term support alternative to Magento Community Edition (CE). vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References