GitHub Advisoryadvisory · PyPI

GHSA-qv8j-hgpc-vrq8 Google Cloud Vertex AI SDK affected by Stored Cross-Site Scripting (XSS)

HIGH Published 2026-02-20 Modified 2026-02-27 Official page ↗
Aliases
CVE-2026-2472
Ecosystem
PyPI
Packages
google-cloud-aiplatform
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber
Weaknesses
CWE-79
Reviewed
2026-02-20

Affected packages

• PyPI google-cloud-aiplatform: >= 1.98.0, < 1.131.0 → fixed in 1.131.0

Description

Stored Cross-Site Scripting (XSS) in the _genai/_evals_visualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform) versions from 1.98.0 up to (but not including) 1.131.0 allows an unauthenticated remote attacker to execute arbitrary JavaScript in a victim's Jupyter or Colab environment via injecting script escape sequences into model evaluation results or dataset JSON data.

Related

Alias · CVE (1)

  • CVE-2026-2472 Stored Cross-Site Scripting (XSS) in the _genai/_evals_visualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform)… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References