GitHub Advisoryadvisory · npm
GHSA-qvjc-g5vr-mfgr Regular Expression Denial of Service in papaparse
HIGH
Official page ↗
- Aliases
- CVE-2020-36649
- Ecosystem
- npm
- Packages
- papaparse
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-185
- Reviewed
- 2020-08-31
Affected packages
• npm papaparse: < 5.2.0 → fixed in 5.2.0
Description
Versions of `papaparse` prior to 5.2.0 are vulnerable to Regular Expression Denial of Service (ReDos). The `parse` function contains a malformed regular expression that takes exponentially longer to process non-numerical inputs. This allows attackers to stall systems and lead to Denial of Service.
Recommendation
Upgrade to version 5.2.0 or later.
Related
Alias · CVE (1)
- CVE-2020-36649 A vulnerability was found in mholt PapaParse up to 5.1.x. vulnerability
Weakness · CWE (1)
- CWE-185 Incorrect Regular Expression weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-36649 advisory
- https://github.com/mholt/PapaParse/issues/777 web
- https://github.com/mholt/PapaParse/pull/779 web
- https://github.com/mholt/PapaParse/commit/235a12758cd77266d2e98fd715f53536b34ad621 web
- https://github.com/mholt/PapaParse package
- https://github.com/mholt/PapaParse/releases/tag/5.2.0 web
- https://snyk.io/vuln/SNYK-JS-PAPAPARSE-564258 web
- https://vuldb.com/?ctiid.218004 web
- https://vuldb.com/?id.218004 web