GitHub Advisoryadvisory · Maven
GHSA-qvmf-36h5-3f5v Improper Input Validation in Jenkins Script Security Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2110
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:script-security
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-06-24
Affected packages
• Maven org.jenkins-ci.plugins:script-security: < 1.70 → fixed in 1.70
Description
Sandbox protection in Jenkins Script Security Plugin 1.69 and earlier could be circumvented during the script compilation phase by applying AST transforming annotations to imports or by using them inside of other annotations.
Related
Alias · CVE (1)
- CVE-2020-2110 Sandbox protection in Jenkins Script Security Plugin 1.69 and earlier could be circumvented during the script compilation phase by applying… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness