GitHub Advisoryadvisory · npm

GHSA-qvqv-mcxr-x8qw Slim Select has potential Cross-site Scripting issue

MEDIUM Published 2024-10-02 Modified 2024-10-18 Official page ↗
Aliases
CVE-2024-9440
Ecosystem
npm
Packages
slim-select
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-10-08

Affected packages

• npm slim-select: >= 2.0.0, < 2.9.2 → fixed in 2.9.2

Description

Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. This vulnerability is fixed in 2.9.2.

Related

Alias · CVE (1)

  • CVE-2024-9440 Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References