GitHub Advisoryadvisory · Packagist
GHSA-qvwr-p3hj-j6jf Magento vulnerable to privilege escalation due to incorrect authorization
MEDIUM
Official page ↗
- Aliases
- CVE-2025-54267
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-10-21
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha3 → fixed in 2.4.9-alpha3
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p3 → fixed in 2.4.8-p3
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p8 → fixed in 2.4.7-p8
• Packagist magento/community-edition: < 2.4.6-p13 → fixed in 2.4.6-p13
• Packagist magento/community-edition: 2.4.8 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
Description
Magento versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by an Incorrect Authorization vulnerability. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain unauthorized access to elevated privileges that increase integrity impact to high. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-54267 Adobe Commerce versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by an Incorrect… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness