GitHub Advisoryadvisory · npm
GHSA-qw3g-35hc-fcrh Cross-Site Scripting (XSS) in restify
MEDIUM
Official page ↗
- Aliases
- CVE-2017-16018
- Ecosystem
- npm
- Packages
- restify
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm restify: >= 2.0.0, < 4.1.0 → fixed in 4.1.0
Description
Affected versions of `restify` are susceptible to a cross-site scripting vulnerability when using URL encoded script tags in a non-existent URL.
Proof of Concept:
Request
```
https://localhost:3000/no5_such3_file7.pl?%22%3E%3Cscript%3Ealert(73541);%3C/script%3E
```
Will be included in response:
```alert(73541);```
Recommendation
Update to version 4.1.0 or later.
Related
Alias · CVE (1)
- CVE-2017-16018 Restify is a framework for building REST APIs. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness