GitHub Advisoryadvisory · npm
GHSA-qw6h-vgh9-j6wx express vulnerable to XSS via response.redirect()
LOW
Official page ↗
- Aliases
- CVE-2024-43796
- Ecosystem
- npm
- Packages
- express
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2024-09-10
Affected packages
• npm express: < 4.20.0 → fixed in 4.20.0
• npm express: >= 5.0.0-alpha.1, < 5.0.0 → fixed in 5.0.0
Description
Impact
In express <4.20.0, passing untrusted user input - even after sanitizing it - to `response.redirect()` may execute untrusted code
Patches
this issue is patched in express 4.20.0
Workarounds
users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist
Details
successful exploitation of this vector requires the following:
1. The attacker MUST control the input to response.redirect()
1. express MUST NOT redirect before the template appears
1. the browser MUST NOT complete redirection before:
1. the user MUST click on the link in the template
Related
Alias · CVE (1)
- CVE-2024-43796 Express.js minimalist web framework for node. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness